HomeImage Archive

Discussions about the Image Archive (any StudioLine product)

Photo Classic v4 Overlay Text During Export 

Wayne Hewitt
Wayne Hewitt
Posts: 34


8/21/2014
Wayne Hewitt
Wayne Hewitt
Posts: 34
I have been doing this for some time but as of a few days ago when I choose to overlay text on the export dialog it brings up a preview/detail screen showing the image with the text very small defaulted to the lower right with no apparent method to edit the settings. I notice that the export form is the same as it was in v3, not like what is shown in the help for v4
edited by wdhewitt on 8/21/2014
0 link
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85


8/22/2014
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85
Hi Wayne,
I suppose there may be more than one issue here.
>> I notice that the export form is the same as it was in v3, not like what is shown in the help for v4 <<

I'm including a screen shot of what the export looks like in my system. If yours is markedly different, then I recommend you reproduce the problem and then immediately use the "Service Request" function in the Help menu to forward your diagnostic logs files to our development team so that we can try to figure out why your Export screen looks like version 3.
>> as of a few days ago when I choose to overlay text on the export dialog it brings up a preview/detail screen showing the image with the text very small defaulted to the lower right with no apparent method to edit the settings. <<
As you can see in my screen shot, selecting that option in the Export panel SHOULD open the "Text" panel to control size, position, content, etc. of the overlay. Maybe there is some strange combination, where that panel is hidden beyond the visible portion of your screen, or covered by some other objects on your screen.
Of course, our software should always "pop up" any screens to the "front" of all other windows, and if necessary shift them to visible screen coordinates. So, here to, a service request might enable our developers to figure out where that "Text" panel is hiding in your case and what necessary "action" our software is currently omitting.


0 link
Wayne Hewitt
Wayne Hewitt
Posts: 34


8/22/2014
Wayne Hewitt
Wayne Hewitt
Posts: 34
Wayne Hewitt wrote:
Andy Schmidt wrote:
Hi Wayne,
I suppose there may be more than one issue here.
>> I notice that the export form is the same as it was in v3, not like what is shown in the help for v4 <<

I'm including a screen shot of what the export looks like in my system. If yours is markedly different, then I recommend you reproduce the problem and then immediately use the "Service Request" function in the Help menu to forward your diagnostic logs files to our development team so that we can try to figure out why your Export screen looks like version 3.
>> as of a few days ago when I choose to overlay text on the export dialog it brings up a preview/detail screen showing the image with the text very small defaulted to the lower right with no apparent method to edit the settings. <<
As you can see in my screen shot, selecting that option in the Export panel SHOULD open the "Text" panel to control size, position, content, etc. of the overlay. Maybe there is some strange combination, where that panel is hidden beyond the visible portion of your screen, or covered by some other objects on your screen.
Of course, our software should always "pop up" any screens to the "front" of all other windows, and if necessary shift them to visible screen coordinates. So, here to, a service request might enable our developers to figure out where that "Text" panel is hiding in your case and what necessary "action" our software is currently omitting.


Attachments:
Photo Classic 4.jpg
0 link
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85


8/22/2014
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85
Hi Wayne,
Your screen shot shows that:
  • you had selected the photo P13805800 in the Image Archive, usually by clicking on the thumbnail ONCE (but there are various other ways to select objects in Windows apps.)
  • You opened the context menu for that object - possibly by right mouse button the image "P13805800".
  • On the context menu you "somehow" highlighted the "Export" function.
HERE is where it gets interesting. Your screen shot almost looks as if you are NOT using a normal mouse to operate StudioLine, but possibly attempt to use other means to navigate the program's GUI?
Up to that moment, all is still fairly completely standard, as far as I can tell.
Once you CLICK on the Export function in that context menu on your screen shot, or, if you use the "File" menu and choose "Export / Save(As)" from there, the context menu would INSTANTLY CLOSE, and instead the "EXPORT OBJECT AS" panel (the left screen on my screen shot) would have opened. Then you'd select the option for "Text Overlay" and press the "Preview/Detail Settings" button right below, then the special "Preview / Detail Settings" screen opens, which is the RIGHT window in my screen shot.
Now..., the fact that your screen shot still shows the context menu being open, seems to imply that you never actually clicked your left mouse button on the "Export" item in the context menu. It almost seems that instead of using your mouse, you press the ENTER key on your keyboard?
Pressing the Enter key (or possibly Alt+Enter, if your "Alt" key is stuck) is the Windows shortcut for "Open". Since the image "P13805800" is currently select, pressing "Enter" will OPEN the image - meaning the normal Image Viewer opens - which is exactly what we DO see on your screen shot...
So - I might have some details wrong, and hopefully you'll fill in the blanks by describing your specific actions - and what "pointing device" or alternate methods you were using - but based on the screen shot it seems as if you never actually launched the "Export" function. The context menu is still sitting there WAITING for you to PICK something off the menu.
0 link
Wayne Hewitt
Wayne Hewitt
Posts: 34


8/22/2014
Wayne Hewitt
Wayne Hewitt
Posts: 34
Actually I sent three screen shots but two appear not to have made it. I used the mouse exclusively - a MS ARC mouse which I have used for some time, including for v3, and until this incident, with v4. The highlighting was just from 'mouseover'. In fact the export does take place. I will resubmit with better captures and details.
0 link
Wayne Hewitt
Wayne Hewitt
Posts: 34


8/22/2014
Wayne Hewitt
Wayne Hewitt
Posts: 34
File names describe actions. All actions by MS ARC mouse. No key presses. Nothing hidden on screen. Logfiles.zip attached.





x SLPC4 01 - Selected.jpg
x SLPC4 02 - Right clicked to get context menu.jpg
x SLPC4 03 - click Export (save as) get Export form - overlay text is off.jpg
x SLPC4 04 - Click Overlay Text get preview detail settings.jpg
x SLPC4 05 - clicked Image Settings dropdown - closed when screen capture tried.jpg
x SLPC4 06 - Click OK this is image exported.jpg
x StudioLine logfiles.zip







"", "", "", "", "", "", ""

0 link
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85


8/23/2014
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85
Hi Wayne,

thanks for all the screen shots.

So - it appears that everything is working and you are able to get to every screen. You are able to turn on/off the overlay text feature successfully?

Now, when you click on the "Overlay Text" line in the feature list of the Export panel, that shoud open the "Text" settings, where you would control WHAT the overlay looks like, WHERE it is aligned in the picture, WHAT the text is, WHAT the size is, etc. etc. Can you open that screen, too?

At this point, can you help me understand your specific problem/concern. It sounds as if things are working just fine. I had operated under the assumption that you did NOT see the right screens, that they were of the wrong product version etc.

What precisely it is that you would like to be different? Is your concern that they text overlay is turned on by default, is it the default size and position... ? Can you point me to something on your screen shots that you expected to behave/look differently?



Attachments:
Text.jpg
0 link
Wayne Hewitt
Wayne Hewitt
Posts: 34


8/23/2014
Wayne Hewitt
Wayne Hewitt
Posts: 34
The issue is that I can not see the final text box to adjust the text to what I use for my default. My original comment about v3 vs v4 had to do with the first context form but on review I realize that the video used the File dropdown, not the right click context menu. Sorry for the missdirection.

I also just now tried some other Saved Settings and the exported image does respond to them correctly. Unfortunately I do not appear to have saved the set I have been using the past few months.

For further background, I am running Win 7 64 and have three flat screens. I have carefully searched behind all displays on all three windows and have found nothing hiding. I have been using this setup for a couple of years and there have been no changes.
.
edited by wdhewitt on 8/23/2014
edited by wdhewitt on 8/23/2014
edited by wdhewitt on 8/23/2014
0 link
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85


8/23/2014
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85
Wayne Hewitt wrote:
I can not see the final text box to adjust the text to what I use for my default. I am running Win 7 64 and have three flat screens. I have carefully searched behind all displays on all three windows and have found nothing hiding. I have been using this setup for a couple of years and there have been no changes.


Hi Wayne - thanks for clarifying. I think I got it now.

I'll have the developers look through the diagnostics log you submitted before the weekend, and search for the "Text" dialog that should open on one of your 3 screens when you click on the "Overlay" line in the list.
0 link
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85


8/23/2014
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85
Hey Wayne - after looking through the diagnostic log you had sent, I noticed that the "Preview/Detailed Settings" dialog opens (as your screen shot confirms), but I don't see the "Text" dialog completing. Instead I see a program exception when reading your original JPEG file.

Can you confirm that you have the same problem with a few different images from different times/sources. If it's something specific to certain images, that it would help us focus our attention on those particular JPEG files - if it seems to happy no matter which image, then we know to look for the reason elsewhere...

Wayne Hewitt wrote:
13:49:46.208 0 251c : 960 Dialog (416) Header : "Export Objects As..."
13:51:48.317 0 251c : 960 Dialog (20891) Header : "Text"
13:51:48.475 0 251c : 960 CSLExportImage::OnPreview - Open Dialog (with Settings)
13:51:48.576 0 251c : 960 Dialog (470) Header : "Preview / Detail Settings - 14202D2B-8AE3-48FB-9631-4A2DCA49D3EF (100%)"
13:51:48.995 0 251c : 960 Dialog (470) Header : "Preview / Detail Settings (100%)"
13:51:48.999 0 251c : 960 CSLExportImage::OnPreview - Dialog opened
13:51:49.163 0251c :2728 Got an exception during read of a JPEG file ("D:\StudioLine3 Data\ACTIVE\Images\Img01118.stg_hm\Pictures\i96643--1x-1.JPG") in ILJpeg.cpp, 1583
0 link
Wayne Hewitt
Wayne Hewitt
Posts: 34


8/24/2014
Wayne Hewitt
Wayne Hewitt
Posts: 34
Andy
I have tried a number of images from different dates and different cameras with what appears to be the same results.
I have attached the log file. Which of the files in the zipped log files are you showing?


edited by wdhewitt on 8/24/2014
edited by Andy Schmidt on 8/24/2014
0 link
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85


8/24/2014
Andy Schmidt
Andy Schmidt
Administrator
Posts: 85
Wayne Hewitt wrote:
tried a number of images from different dates and different cameras with what appears to be the same results.

Thanks for confirming that for me. I checked the log files you attached and see that for the 3 attempts to display the "Text" dialogue, they were each followed by a program exception in the JPEG handler.

So - your result may be related to that program exception.
Wayne Hewitt wrote:
I have attached the log file.


Thanks I downloaded that ZIP file and then DELETED it as the diagnostic logs could contain sensitive information NOT intended for public consumption!

I will let you know what our development team finds out.
0 link






Powered by Jitbit Forum 8.3.8.0 © 2006-2013 Jitbit Software